aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-10-28 11:02:02 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-02 14:59:26 +0100
commitdb539ce16e7d34bf2c71675d1417b7f7172e7e03 (patch)
treea9393074f71f05ea5c6ce4460a8c1136c709196b /meta-python
parentc04f105227101977a0f5ed8d41dd6fbe71138eea (diff)
downloadmeta-openembedded-contrib-db539ce16e7d34bf2c71675d1417b7f7172e7e03.tar.gz
python-lxml: do not overwrite inherited DEPENDS
python-lxml recipe inherits setuptools3 and after that includes python-lxml.inc. In the current situation DEPENDS inherited by setuptools3-tree are overwritten causing: DEBUG: Executing shell function do_compile /home/superandy/tmp/oe-core-glibc/work/x86_64-linux/python3-lxml-native/3.4.4-r0/temp/run.do_compile.30454: line 118: /home/superandy/tmp/oe-core-glibc/sysroots/x86_64-linux/usr/bin/python3-native/python3: No such file or directory ERROR: python3 setup.py build_ext execution failed. WARNING: /home/superandy/tmp/oe-core-glibc/work/x86_64-linux/python3-lxml-native/3.4.4-r0/temp/run.do_compile.30454:1 exit 1 from exit 1 ERROR: Function failed: do_compile (log file is located at /home/superandy/tmp/oe-core-glibc/work/x86_64-linux/python3-lxml-native/3.4.4-r0/temp/log.do_compile.30454) Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-lxml.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc
index 8ca8f41a14..7a596c1da1 100644
--- a/meta-python/recipes-devtools/python/python-lxml.inc
+++ b/meta-python/recipes-devtools/python/python-lxml.inc
@@ -6,7 +6,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
SRCNAME = "lxml"
-DEPENDS = "libxml2 libxslt"
+DEPENDS += "libxml2 libxslt"
SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"