aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commitb13250198de5e1a5461e3e8079cf858cc6a084a3 (patch)
tree38c31d1258057dd9efade90b32a3b4b463dd4d59 /meta-python
parenta7c72d7d7c3948081800ee118e5cd7ee2a146237 (diff)
downloadmeta-openembedded-contrib-b13250198de5e1a5461e3e8079cf858cc6a084a3.tar.gz
python3-lxml: Add new recipe
Use a common .inc file for the python-lxml and python3-lxml recipes. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-lxml.inc31
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_3.4.4.bb34
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb2
3 files changed, 34 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc
new file mode 100644
index 0000000000..9d1bfbcdcb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-lxml.inc
@@ -0,0 +1,31 @@
+SUMMARY = "Python XML bindings for libxml2 and libxslt"
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
+SRCNAME = "lxml"
+
+DEPENDS = "libxml2 libxslt"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
+SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+DISTUTILS_BUILD_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
+RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
index 4fab4f3d5c..81ccb12d87 100644
--- a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
+++ b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
@@ -1,34 +1,2 @@
-SUMMARY = "Python XML bindings for libxml2 and libxslt"
-DESCRIPTION = "Powerful and Pythonic XML processing library combining \
-libxml2/libxslt with the ElementTree API."
-HOMEPAGE = "http://codespeak.net/lxml"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
-SRCNAME = "lxml"
-
-DEPENDS = "libxml2 libxslt"
-
-SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
-SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-DISTUTILS_BUILD_ARGS += " \
- --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
- --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
-"
-
-DISTUTILS_INSTALL_ARGS += " \
- --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
- --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
-"
-
-BBCLASSEXTEND = "native nativesdk"
-
-RDEPENDS_${PN} += "libxml2 libxslt python-compression"
-RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
-
+require python-lxml.inc
diff --git a/meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb b/meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb
new file mode 100644
index 0000000000..ff4bc7faad
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-lxml.inc