aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2015-08-12 15:52:42 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:26 +0200
commita1f5f27f47564c9a3edc963b5efdeb39b8f5532c (patch)
tree65397d6bae1b566972e198bc3c3cf5b6e34b62d9 /meta-python
parent42fcf360806f6131da534af29d40dbfe3d44b408 (diff)
downloadmeta-openembedded-contrib-a1f5f27f47564c9a3edc963b5efdeb39b8f5532c.tar.gz
python-pyinotify: add recipe
Python bindings for Linux inotify mechanism Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb
new file mode 100644
index 0000000000..42956ce421
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring"
+HOMEPAGE = "https://pypi.python.org/pypi/pyinotify"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382"
+
+RDEPENDS_${PN} += "python-threading python-io python-subprocess python-misc python-shell"
+
+SRCNAME = "pyinotify"
+SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406"
+SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools