aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-11-03 04:02:24 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:49:42 +0100
commit9a233d0b7869f00f3c7ec412e172e3d1f72a499a (patch)
tree593b738a1708901c7ff4e0f918c5fdf1511ea6c0 /meta-python
parentad1134f299f072a4095ff2957e063f5b6376f910 (diff)
downloadmeta-openembedded-contrib-9a233d0b7869f00f3c7ec412e172e3d1f72a499a.tar.gz
python-pygpgme: add python-pygpgme 0.3
PyGPGME is a Python module that lets you sign, verify, encrypt and decrypt messages using the OpenPGP format. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme_0.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
new file mode 100644
index 0000000000..f06c34439a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
@@ -0,0 +1,18 @@
+SUMMARY = "A Python module for working with OpenPGP messages"
+DESCRIPTION = "PyGPGME is a Python module that lets you sign, verify, \
+ encrypt and decrypt messages using the OpenPGP format."
+HOMEPAGE = "https://launchpad.net/pygpgme"
+SECTION = "devel/python"
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pygpgme/pygpgme-${PV}.tar.gz"
+SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0"
+SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1"
+
+S = "${WORKDIR}/pygpgme-${PV}"
+
+DEPENDS += "gpgme"
+
+inherit setuptools