aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authormike.looijmans@topic.nl <mike.looijmans@topic.nl>2015-09-13 21:01:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:37:19 +0200
commit75679d4422f8080550cd96e8e8f097ee98784853 (patch)
tree6f44b487f802dfc4d2291745329fdf6ae4b5ad0d /meta-python
parenta6423360a175a5e8515c0c6f97d711850dc96c53 (diff)
downloadmeta-openembedded-contrib-75679d4422f8080550cd96e8e8f097ee98784853.tar.gz
python-pyopenssl: Add missing RDEPENDS on "six" and "cryptography"
Fixes the following errors when doing "import OpenSSL": File "/usr/lib/python2.7/site-packages/OpenSSL/_util.py", line 6, in <module> from cryptography.hazmat.bindings.openssl.binding import Binding ImportError: No module named cryptography.hazmat.bindings.openssl.binding File "/usr/lib/python2.7/site-packages/OpenSSL/rand.py", line 9, in <module> from six import integer_types as _integer_types ImportError: No module named six Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
index 7f9301299d..d80e6667ae 100644
--- a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
@@ -21,5 +21,5 @@ inherit setuptools
PACKAGES =+ "${PN}-tests"
FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
-RDEPENDS_${PN} = "python-threading"
+RDEPENDS_${PN} = "python-threading python-six python-cryptography"
RDEPENDS_${PN}-tests = "${PN}"