aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commit4058807b84c52438b6dbda967875ab1a74b35655 (patch)
tree021863da5de54a883335a92917d2214baea67c51 /meta-python
parent29aa76af6579f95340488d2b5ba6fb66f8ea2771 (diff)
downloadmeta-openembedded-contrib-4058807b84c52438b6dbda967875ab1a74b35655.tar.gz
python3-decorator: Add new recipe
Use a common .inc file for the python-decorator and python3-decorator recipes. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-decorator.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-decorator_4.0.2.bb22
-rw-r--r--meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb2
3 files changed, 23 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator.inc b/meta-python/recipes-devtools/python/python-decorator.inc
new file mode 100644
index 0000000000..2c230ff269
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-decorator.inc
@@ -0,0 +1,20 @@
+SUMMARY = "Python decorator utilities"
+HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0"
+
+SRCNAME = "decorator"
+
+SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7"
+SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206"
diff --git a/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb b/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb
index bda0d713df..f262168467 100644
--- a/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb
@@ -1,22 +1,2 @@
-SUMMARY = "Python decorator utilities"
-HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
-DESCRIPTION = "\
-The aim of the decorator module it to simplify the usage of decorators \
-for the average programmer, and to popularize decorators by showing \
-various non-trivial examples. Of course, as all techniques, decorators \
-can be abused and you should not try to solve every problem with a \
-decorator, just because you can."
-
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0"
-
-SRCNAME = "decorator"
-
-SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7"
-SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206"
+require python-decorator.inc
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb b/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb
new file mode 100644
index 0000000000..844cbdc9a9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-decorator.inc