aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2015-05-20 16:26:46 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-22 20:14:07 +0200
commit2b79eeb404af36cffb3f12097175556e5819a88d (patch)
treec2cd8cd1381807cdab1f337e58a611b0e17bb641 /meta-python
parent61a66773ce105f2f0eef6b464ecaf8b8aa531ed7 (diff)
downloadmeta-openembedded-contrib-2b79eeb404af36cffb3f12097175556e5819a88d.tar.gz
psutil: update to newer version (2.2.1)
Convert to pypi recipe. Account for dependency on python-subprocess. Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-psutil_0.6.1.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-psutil_2.2.1.bb12
2 files changed, 12 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-psutil_0.6.1.bb b/meta-python/recipes-devtools/python/python-psutil_0.6.1.bb
deleted file mode 100644
index ff113d0f24..0000000000
--- a/meta-python/recipes-devtools/python/python-psutil_0.6.1.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "A cross-platform process and system utilities module for Python"
-SECTION = "devel/python"
-HOMEPAGE = "http://code.google.com/p/psutil"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
-
-SRC_URI = "http://psutil.googlecode.com/files/psutil-${PV}.tar.gz"
-SRC_URI[md5sum] = "3cfcbfb8525f6e4c70110e44a85e907e"
-SRC_URI[sha256sum] = "d665a4cc58c9a5d207fb0dc9869fc0ee10f4f66ad885e84886ef6339ccce0a6f"
-
-S = "${WORKDIR}/psutil-${PV}"
-
-inherit setuptools
-
diff --git a/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb b/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb
new file mode 100644
index 0000000000..326d668400
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-psutil_2.2.1.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
+
+SRC_URI[md5sum] = "1a2b58cd9e3a53528bb6148f0c4d5244"
+SRC_URI[sha256sum] = "a0e9b96f1946975064724e242ac159f3260db24ffa591c3da0a355361a3a337f"
+
+RDEPENDS_${PN} += " \
+ python-subprocess \
+ "
+
+inherit pypi