aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2016-09-07 15:37:37 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:47 +0200
commitee23e9d9792a0a923294144a5f5b54a67b74eb84 (patch)
tree437778a07a8784766ff12b3fd3c4d10c05724ff0 /meta-python
parent5641b252766a59497c4d32b70103bb1b96c8d9c0 (diff)
downloadmeta-openembedded-contrib-ee23e9d9792a0a923294144a5f5b54a67b74eb84.tar.gz
python-pylint: python source code analyzer
New recipe which defines the pylint python module: the static code analyzer for python files. Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pylint_1.6.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb b/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb
new file mode 100644
index 0000000000..b9219dd28e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb
@@ -0,0 +1,27 @@
+SUMMARY="Pylint is a Python source code analyzer"
+HOMEPAGE= "http://www.pylint.org/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
+
+SRC_URI[md5sum] = "66ba9c27e067568bdabcdd7c21303903"
+SRC_URI[sha256sum] = "ef901a34b62ed7a734370ba5b162d890231ba8822abe88c6dda1268e2575f5f1"
+
+RDEPENDS_${PN} += "python-codecs \
+ python-contextlib \
+ python-core \
+ python-distutils \
+ python-io \
+ python-lang \
+ python-multiprocessing \
+ python-netserver \
+ python-numbers \
+ python-pickle \
+ python-re \
+ python-shell \
+ python-six \
+ python-stringold \
+ python-subprocess \
+ python-textutils \
+ python-unittest"
+
+inherit pypi setuptools