aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-04-13 10:16:52 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-21 21:33:19 +0200
commitcb95c5edaa977c8361628dab04b95192c423fc1a (patch)
tree8385d257d84debc16e1f24772f7e17e4ef348066 /meta-python
parentbfa6d1c090250a2f8ac2232176f109c5ebc3dc66 (diff)
downloadmeta-openembedded-contrib-cb95c5edaa977c8361628dab04b95192c423fc1a.tar.gz
python-bcrypt: Add recipe for version 2.0.0
It's a modern password hashing for your software and your servers. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb b/meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb
new file mode 100644
index 0000000000..3cbe33eb52
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Modern password hashing for your software and your servers."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e19d0fe40c5ce4109e6bcbf4aab2a5bd"
+
+DEPENDS = "python-cffi-native"
+
+SRC_URI[md5sum] = "e7fb17be46904cdb2ae6a062859ee58c"
+SRC_URI[sha256sum] = "8b2d197ef220d10eb74625dde7af3b10daa973ae9a1eadd6366f763fad4387fa"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-cffi \
+ python-six \
+"