aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-17 10:17:41 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:27 +0200
commit6e17cf09980afc69f9942b3dc63350578496859a (patch)
tree33bfa43f5462c96fd1e0a9bfcfe8e2223980215c /meta-python
parent4efb76b1aad1d69933e91ae16508bc8022399b2a (diff)
downloadmeta-openembedded-contrib-6e17cf09980afc69f9942b3dc63350578496859a.tar.gz
python-progress, python3-progress: Add recipe for version 1.2
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-progress.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-progress_1.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-progress_1.2.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-progress.inc b/meta-python/recipes-devtools/python/python-progress.inc
new file mode 100644
index 0000000000..80d0a58450
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-progress.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Easy progress reporting for Python"
+HOMEPAGE = "http://github.com/verigak/progress/"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=aef5566ac4fede9815eccf124c281317"
+
+SRC_URI[md5sum] = "c1dbf49a41e80408d3874d976ba894cc"
+SRC_URI[sha256sum] = "5b6a50f9ac76820f619d7789b5354881c8c10060a64047e415868d8f503cc2eb"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-progress_1.2.bb b/meta-python/recipes-devtools/python/python-progress_1.2.bb
new file mode 100644
index 0000000000..80608627a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-progress_1.2.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-progress.inc
diff --git a/meta-python/recipes-devtools/python/python3-progress_1.2.bb b/meta-python/recipes-devtools/python/python3-progress_1.2.bb
new file mode 100644
index 0000000000..45e2642133
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-progress_1.2.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-progress.inc