aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:20 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:37 +0200
commit6a144af2f108575c3eabad9ae4cbcc1c2b902052 (patch)
tree188d12383f0fceb923fda7d4263df0ffaa5b3737 /meta-python
parent775a576d2e62d17f4a4b4c24e117ab5241c646de (diff)
downloadmeta-openembedded-contrib-6a144af2f108575c3eabad9ae4cbcc1c2b902052.tar.gz
python-pyopenssl: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb2
3 files changed, 21 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl.inc b/meta-python/recipes-devtools/python/python-pyopenssl.inc
new file mode 100644
index 0000000000..88b4306068
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyopenssl.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Simple Python wrapper around the OpenSSL library"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "openssl ${PYTHON_PN}-cryptography"
+
+SRC_URI[md5sum] = "9587d813dcf656e9f2760e41a3682dc3"
+SRC_URI[sha256sum] = "363d10ee43d062285facf4e465f4f5163f9f702f9134f0a5896f134cbb92d17d"
+
+PYPI_PACKAGE = "pyOpenSSL"
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN} = "python-threading python-six python-cryptography"
+RDEPENDS_${PN}-tests = "${PN}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb b/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
index 81738588bf..d7177e2d15 100644
--- a/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
@@ -1,17 +1,2 @@
-SUMMARY = "Simple Python wrapper around the OpenSSL library"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-DEPENDS = "openssl python-cryptography"
-
-SRC_URI[md5sum] = "9587d813dcf656e9f2760e41a3682dc3"
-SRC_URI[sha256sum] = "363d10ee43d062285facf4e465f4f5163f9f702f9134f0a5896f134cbb92d17d"
-
-PYPI_PACKAGE = "pyOpenSSL"
inherit pypi setuptools
-
-PACKAGES =+ "${PN}-tests"
-FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
-
-RDEPENDS_${PN} = "python-threading python-six python-cryptography"
-RDEPENDS_${PN}-tests = "${PN}"
+require python-pyopenssl.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb b/meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb
new file mode 100644
index 0000000000..0f0f83e3a2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pyopenssl.inc