aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:17 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:36 +0200
commit57ce75d5fd3055812c03455b0f1658bfcdf4173b (patch)
treeae61ecbd96d8e3e2189bf46ee308db02d2425ac4 /meta-python
parent559ec4040e9b2841e986a77bdaf7acd21e15937b (diff)
downloadmeta-openembedded-contrib-57ce75d5fd3055812c03455b0f1658bfcdf4173b.tar.gz
python-idna: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-idna.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-idna_2.1.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-idna_2.1.bb2
3 files changed, 12 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-idna.inc b/meta-python/recipes-devtools/python/python-idna.inc
new file mode 100644
index 0000000000..8e1fcb42b1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-idna.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Internationalised Domain Names in Applications"
+HOMEPAGE = "https://github.com/kjd/idna"
+LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=134bdad79491c37bdae32811572b4bc6"
+
+SRC_URI[md5sum] = "f6473caa9c5e0cc1ad3fd5d04c3c114b"
+SRC_URI[sha256sum] = "ed36f281aebf3cd0797f163bb165d84c31507cedd15928b095b1675e2d04c676"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-idna_2.1.bb b/meta-python/recipes-devtools/python/python-idna_2.1.bb
index 90f47aea9e..2dcf72a292 100644
--- a/meta-python/recipes-devtools/python/python-idna_2.1.bb
+++ b/meta-python/recipes-devtools/python/python-idna_2.1.bb
@@ -1,11 +1,2 @@
-SUMMARY = "Internationalised Domain Names in Applications"
-HOMEPAGE = "https://github.com/kjd/idna"
-LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=134bdad79491c37bdae32811572b4bc6"
-
-DEPENDS += "python-pip"
-
-SRC_URI[md5sum] = "f6473caa9c5e0cc1ad3fd5d04c3c114b"
-SRC_URI[sha256sum] = "ed36f281aebf3cd0797f163bb165d84c31507cedd15928b095b1675e2d04c676"
-
inherit pypi setuptools
+require python-idna.inc
diff --git a/meta-python/recipes-devtools/python/python3-idna_2.1.bb b/meta-python/recipes-devtools/python/python3-idna_2.1.bb
new file mode 100644
index 0000000000..a08ca714ac
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-idna_2.1.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-idna.inc