aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:15 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:35 +0200
commit445e595c9dc01d475df8d9ffd8b6823c1d2c4d6a (patch)
tree553a24d9751ea9b1cd06236db3320592c6664963 /meta-python
parent90eedcc9fec081d597e73c31119fe2c493cac8a4 (diff)
downloadmeta-openembedded-contrib-445e595c9dc01d475df8d9ffd8b6823c1d2c4d6a.tar.gz
python-cffi: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cffi.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-cffi_1.7.0.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb2
3 files changed, 12 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-cffi.inc b/meta-python/recipes-devtools/python/python-cffi.inc
new file mode 100644
index 0000000000..7038d90a96
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cffi.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Foreign Function Interface for Python calling C code"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
+DEPENDS = "libffi ${PYTHON_PN}-pycparser"
+
+SRC_URI[md5sum] = "34122a545060cee58bab88feab57006d"
+SRC_URI[sha256sum] = "6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb b/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb
index 6f4d77a4ef..1d2d2416af 100644
--- a/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb
@@ -1,11 +1,2 @@
-SUMMARY = "Foreign Function Interface for Python calling C code"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
-DEPENDS = "libffi python-pycparser"
-
-SRC_URI[md5sum] = "34122a545060cee58bab88feab57006d"
-SRC_URI[sha256sum] = "6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df"
-
inherit pypi setuptools
-
-BBCLASSEXTEND = "native"
+require python-cffi.inc
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb b/meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb
new file mode 100644
index 0000000000..e888084347
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-cffi.inc