aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:31 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:39 +0200
commit43895d9420853a1a4d3cdb4446998b29e90300c6 (patch)
treefc28044498cef23ece5b7d16397cf0f3c8021ae6 /meta-python
parent97691e5ace620a27685ba5e06964503da7bf2915 (diff)
downloadmeta-openembedded-contrib-43895d9420853a1a4d3cdb4446998b29e90300c6.tar.gz
python-prompt-toolkit, python3-prompt-toolkit: Add recipe for version 1.0.6
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-prompt-toolkit.inc19
-rw-r--r--meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.6.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.6.bb9
3 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-prompt-toolkit.inc b/meta-python/recipes-devtools/python/python-prompt-toolkit.inc
new file mode 100644
index 0000000000..ac860b7639
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-prompt-toolkit.inc
@@ -0,0 +1,19 @@
+SUMMARY = "Library for building powerful interactive command lines in Python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
+
+SRC_URI[md5sum] = "9e0be24993b13b204e04ffd20b2873d2"
+SRC_URI[sha256sum] = "fa8f0c3668afbc85abbb4601ebc8db1db9d5009c8a833feea107fc63f1e7ef22"
+
+PYPI_PACKAGE = "prompt_toolkit"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-wcwidth \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.6.bb b/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.6.bb
new file mode 100644
index 0000000000..76e841014a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.6.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-prompt-toolkit.inc
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.6.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.6.bb
new file mode 100644
index 0000000000..d8f6389cc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.6.bb
@@ -0,0 +1,9 @@
+inherit pypi setuptools3
+require python-prompt-toolkit.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-enum \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-textutils \
+"