aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMikko Ylinen <mikko.ylinen@linux.intel.com>2016-08-30 09:55:45 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:30:52 +0200
commit40a075a5d066c76b4fd8cccadbdc58250b632ea2 (patch)
treef560010276921fbf420382ebb0b8dbcfcde6c91f /meta-python
parent2cdd3d645671a459319caa2d016dd1af6ebe204a (diff)
downloadmeta-openembedded-contrib-40a075a5d066c76b4fd8cccadbdc58250b632ea2.tar.gz
python3-jsonschema: set dependency to vcversioner
The recently added python3-jsonschema depends on vcversioner. The setuptools tries to fetch it but fails with bitbake if run behind proxies. Explicitly set DEPENDS to ensure the dependency is installed before running setup.py for python3-jsonschema. Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
index 5aaee682b6..53b88396fe 100644
--- a/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
@@ -1,6 +1,8 @@
inherit pypi setuptools3
require python-jsonschema.inc
+DEPENDS += "python3-vcversioner"
+
RDEPENDS_${PN} += " \
${PYTHON_PN}-misc \
"