aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:27 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:39 +0200
commit26b10138433e5d35f19680f6cdf515736936a179 (patch)
tree60c851092624bc4120a66544dea8da460ea092e9 /meta-python
parented70cd5761cf531fb5d71b02e901c43ff2a1aed2 (diff)
downloadmeta-openembedded-contrib-26b10138433e5d35f19680f6cdf515736936a179.tar.gz
python-requests, python3-requests: Update to version 2.11.1
This commit also change RDEPENDS code style and add python-urllib3 as runtime dependence. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-requests.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.11.1.bb (renamed from meta-python/recipes-devtools/python/python-requests_2.11.0.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.11.1.bb (renamed from meta-python/recipes-devtools/python/python3-requests_2.11.0.bb)0
3 files changed, 12 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-requests.inc b/meta-python/recipes-devtools/python/python-requests.inc
index 66dd9cd2e0..287078abe5 100644
--- a/meta-python/recipes-devtools/python/python-requests.inc
+++ b/meta-python/recipes-devtools/python/python-requests.inc
@@ -3,9 +3,18 @@ HOMEPAGE = "http://python-requests.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d9bb3515869c0f426cb8441c899ae7f5"
-SRC_URI[md5sum] = "147afc07d8967cf46359701551a6cb69"
-SRC_URI[sha256sum] = "b2ff053e93ef11ea08b0e596a1618487c4e4c5f1006d7a1706e3671c57dea385"
+SRC_URI[md5sum] = "ad5f9c47b5c5dfdb28363ad7546b0763"
+SRC_URI[sha256sum] = "5acf980358283faba0b897c73959cecf8b841205bb4b2ad3ef545f46eae1a133"
-RDEPENDS_${PN} = "${PYTHON_PN}-email ${PYTHON_PN}-json ${PYTHON_PN}-netserver"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-ndg-httpsclient \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-urllib3 \
+"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.11.0.bb b/meta-python/recipes-devtools/python/python-requests_2.11.1.bb
index 627bc95d8a..627bc95d8a 100644
--- a/meta-python/recipes-devtools/python/python-requests_2.11.0.bb
+++ b/meta-python/recipes-devtools/python/python-requests_2.11.1.bb
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.11.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.11.1.bb
index 5e869b7883..5e869b7883 100644
--- a/meta-python/recipes-devtools/python/python3-requests_2.11.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests_2.11.1.bb