aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-21 17:08:14 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:28 +0200
commit4ebcca667038218191cd28156f9236ea4a63ad1f (patch)
treefc098628c26756df4d5d986d9d4624d100a6bad6 /meta-python
parentd1d2775a3a7b2e83ee3caf9e5c24dcaa16bbbedc (diff)
downloadmeta-openembedded-contrib-4ebcca667038218191cd28156f9236ea4a63ad1f.tar.gz
python-ply: add new recipe
python-ply: PLY is yet another implementation of lex and yacc for Python. It's required by python-pysmi. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-ply_3.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-ply_3.10.bb b/meta-python/recipes-devtools/python/python-ply_3.10.bb
new file mode 100644
index 0000000000..8e61efa796
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ply_3.10.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python Lex and Yacc"
+DESCRIPTION = "Python ply: PLY is yet another implementation of lex and yacc for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/ply"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://README.md;beginline=3;endline=30;md5=fcb04bc2f765e46ab7084d6ab6e452bb"
+
+SRCNAME = "ply"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "1d63c166ab250bab87d8dcc42dcca70e"
+SRC_URI[sha256sum] = "96e94af7dd7031d8d6dd6e2a8e0de593b511c211a86e28a9c9621c275ac8bacb"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools