aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2016-07-04 16:06:16 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:32 +0200
commitf735a9ca62a91431df1cf74901000b6ecb386459 (patch)
tree389bd40dd9d728b603333ad5dafa1171172c9a1e /meta-python
parenta9b7ae5427ea2dc0fe24154eef8d841e6bbe7a56 (diff)
downloadmeta-openembedded-contrib-f735a9ca62a91431df1cf74901000b6ecb386459.tar.gz
python-setuptools-scm: Add python-setuptools-scm bb
* Add python-setuptools-scm bb as python-pytest-runner depends on python-setuptools-scm Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Acked-by: Tim Orling (Intel OpenSource Technology Center) < Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm_1.11.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm_1.11.1.bb b/meta-python/recipes-devtools/python/python-setuptools-scm_1.11.1.bb
new file mode 100644
index 0000000000..2a3b97d832
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm_1.11.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "the blessed package to manage your versions by scm tags"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=838c366f69b72c5df05c96dff79b35f2"
+
+inherit pypi setuptools
+
+SRCNAME = "setuptools_scm"
+
+SRC_URI = "https://pypi.python.org/packages/84/aa/c693b5d41da513fed3f0ee27f1bf02a303caa75bbdfa5c8cc233a1d778c4/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "4d19b2bc9580016d991f665ac20e2e8f"
+SRC_URI[sha256sum] = "8c45f738a23410c5276b0ed9294af607f491e4260589f1eb90df8312e23819bf"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json"
+
+