aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-07-09 15:54:59 +0800
committerKhem Raj <raj.khem@gmail.com>2020-07-12 19:04:17 -0700
commitc64a73b3edaaccde08be9d4f543c225f7e7bf686 (patch)
treec7d56560989b3a8e54fe6caf4065a32397ce8424 /meta-python/recipes-extended
parent3cf73983b7c742b4cffcda488e1515a186c484b1 (diff)
downloadmeta-openembedded-contrib-c64a73b3edaaccde08be9d4f543c225f7e7bf686.tar.gz
python3-pykickstart: 3.22 -> 3.26
Update python3-pykickstart from 3.22 to 3.26. * Update context of 0001-support-authentication-for-kickstart.patch Signed-off-by: Kai Kang <kai.kang@windriver.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch10
-rw-r--r--meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb (renamed from meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb)2
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch b/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch
index e7533f4769..0e64ce420e 100644
--- a/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch
+++ b/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch
@@ -32,10 +32,10 @@ index bf08ac5..aada7aa 100644
And some warning classes:
KickstartWarning - A generic warning class.
-@@ -131,3 +134,17 @@ class KickstartDeprecationWarning(KickstartParseWarning, DeprecationWarning):
+@@ -125,3 +128,17 @@ class KickstartDeprecationWarning(KickstartParseWarning, DeprecationWarning):
+ """A class for warnings occurring during parsing related to using deprecated
commands and options.
"""
- pass
+
+class KickstartAuthError(KickstartError):
+ """An exception for errors relating to authentication failed while
@@ -43,7 +43,7 @@ index bf08ac5..aada7aa 100644
+ """
+ def __init__(self, msg):
+ """Create a new KickstartAuthError exception instance with the
-+ descriptive message val. val should be the return value of
++ descriptive message val. val should be the return value of
+ formatErrorMsg.
+ """
+ KickstartError.__init__(self, msg)
@@ -125,7 +125,7 @@ diff --git a/pykickstart/parser.py b/pykickstart/parser.py
index d8880eb..22d14cb 100644
--- a/pykickstart/parser.py
+++ b/pykickstart/parser.py
-@@ -787,7 +787,7 @@ class KickstartParser(object):
+@@ -801,7 +801,7 @@ class KickstartParser(object):
i = PutBackIterator(s.splitlines(True) + [""])
self._stateMachine(i)
@@ -134,7 +134,7 @@ index d8880eb..22d14cb 100644
"""Process a kickstart file, given by the filename f."""
if reset:
self._reset()
-@@ -808,7 +808,7 @@ class KickstartParser(object):
+@@ -822,7 +822,7 @@ class KickstartParser(object):
self.currentdir[self._includeDepth] = cd
try:
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb
index 041abd3e8d..7aeb5d6c99 100644
--- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb
+++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=ma
file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \
file://0004-load.py-retry-to-invoke-request-with-timeout.patch \
"
-SRCREV = "674c17b1e231f56a0d8a5ced4a204cdbc4c1edf3"
+SRCREV = "4c93e84c8798da511da1c05f1912d2f908f8f85f"
UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"