aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-29 15:12:24 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-30 07:50:03 -0700
commit588d32cae447f45073a92a772643dbdfaab64e7b (patch)
tree9f590c831ef2113e1b085619d88c4555087a3264 /meta-python/recipes-extended
parente14031a776a32ef30c703b4e55e26a5def5c696c (diff)
downloadmeta-openembedded-contrib-588d32cae447f45073a92a772643dbdfaab64e7b.tar.gz
python3-pyparted: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted.inc22
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb23
2 files changed, 21 insertions, 24 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
deleted file mode 100644
index 97054487f9..0000000000
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
-an interface to libparted, the GNU parted library for disk partitioning and \
-filesystem manipulation."
-SUMMARY = "Python bindings for libparted"
-HOMEPAGE = "https://github.com/rhinstaller/pyparted"
-LICENSE = "GPL-2.0+"
-LIC_FILES_CHKSUM = "\
- file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
- file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
-"
-DEPENDS += "parted"
-
-# upstream only publishes releases in github archives which are discouraged
-SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
-SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
-
-S = "${WORKDIR}/git"
-
-RDEPENDS_${PN}_class-target += " \
- parted (>= 2.3) \
-"
-RDEPENDS_${PN}_class-native = ""
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
index d83901ff3a..a801920c09 100644
--- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
+++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
@@ -1,8 +1,27 @@
-require python-pyparted.inc
+DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
+an interface to libparted, the GNU parted library for disk partitioning and \
+filesystem manipulation."
+SUMMARY = "Python bindings for libparted"
+HOMEPAGE = "https://github.com/rhinstaller/pyparted"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "\
+ file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+ file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
+"
+DEPENDS += "parted"
+
+# upstream only publishes releases in github archives which are discouraged
+SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
+SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
inherit distutils3
-RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math"
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN}_class-target += " \
+ parted (>= 2.3) \
+ python3-stringold python3-codecs python3-math \
+"
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native"