aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-22 02:45:04 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:33:38 -0700
commit3e30cab843e27b9b55b62f8a4fc011f43c5a69b0 (patch)
tree61ef55bc96108a8aaf3db4c6eed1400d3ed327ff /meta-python/recipes-extended
parent303431a3f56e786afce8085572bbf2952a1e9956 (diff)
downloadmeta-openembedded-contrib-3e30cab843e27b9b55b62f8a4fc011f43c5a69b0.tar.gz
python3-pywbemtools: Add recipe
Add release 0.7.1 of the python client tools to work with WBEM Servers using the PyWBEM API: - Pinned prompt-toolkit to <3.0 on Python 3.8 on Windows to avoid WinError 995 - Fixed exception when command entered in interactive mode, on Python 2 - Test: Default connection file does not get restored in some cases during test. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb
new file mode 100644
index 0000000000..05f77288e7
--- /dev/null
+++ b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A set of tools using pywbem"
+DESCRIPTION = "A set of tools using pywbem to communicate with WBEM servers"
+HOMEPAGE = "https://pywbemtools.readthedocs.io/en/stable/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI[md5sum] = "a789da735c04ddc08ba828cd8022243e"
+SRC_URI[sha256sum] = "d2fe776c78a740215142f4f033055093f2283fd9327440c59734716e51e19989"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-pywbem-native \
+ ${PYTHON_PN}-six-native \
+ ${PYTHON_PN}-click-native \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-pywbem \
+ ${PYTHON_PN}-click \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-mock \
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-nocasedict \
+ ${PYTHON_PN}-yamlloader \
+ ${PYTHON_PN}-click-repl \
+ ${PYTHON_PN}-click-spinner \
+ ${PYTHON_PN}-asciitree \
+ ${PYTHON_PN}-tabulate \
+ ${PYTHON_PN}-pydicti \
+ ${PYTHON_PN}-nocaselist \
+ ${PYTHON_PN}-custom-inherit \
+"
+
+BBCLASSEXTEND = "native"