aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-20 20:17:49 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit1ae31787167240729a78a442a378ef354583c012 (patch)
treea710e2846481058f4743c7f6d3745915116566e7 /meta-python/recipes-extended
parent05d0c5eee319055816bbea8b9dd972f723f68019 (diff)
downloadmeta-openembedded-contrib-1ae31787167240729a78a442a378ef354583c012.tar.gz
meta-python: rename python2 recipes to python3 eqiuvalent
Rename recipes which were previously built with python2 to their python3 equivalents. Use new python3 classes (setuptools3) in those recipes. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-cson/python3-cson_git.bb (renamed from meta-python/recipes-extended/python-cson/python-cson_git.bb)2
-rw-r--r--meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb (renamed from meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb)2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-extended/python-cson/python-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index efb338cf28..5c74c7a307 100644
--- a/meta-python/recipes-extended/python-cson/python-cson_git.bb
+++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
RDEPENDS_${PN}_class-native = ""
DEPENDS_append_class-native = " python-native "
-inherit setuptools
+inherit setuptools3
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb
index 422f0dbc43..38b3c0a4f8 100644
--- a/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
+++ b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb
@@ -9,7 +9,7 @@ SRC_URI[sha256sum] = "607148429f85412915e32265779c0cf6d09f73aa97cf1ff0d101ac22c6
PYPI_PACKAGE = "ephem"
-inherit pypi setuptools
+inherit pypi setuptools3
RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \