aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:37 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:12 -0800
commitdf997e0747decf536fc96f6c3be1adf3056f9f35 (patch)
tree44735f858b42e16fe1061b179f7f6563e229a0c2 /meta-python/recipes-extended
parent49b6db7e66bbff7ec0c1ddbd746c656004527db5 (diff)
downloadmeta-openembedded-contrib-df997e0747decf536fc96f6c3be1adf3056f9f35.tar.gz
Remove deprecated python3-subprocess from the RDEPENDS
The python3-subprocess package was merged into core as part of the json manifest migration Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted.inc1
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb2
2 files changed, 1 insertions, 2 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
index c82909d100..a0ec02817a 100644
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
@@ -18,6 +18,5 @@ S = "${WORKDIR}/git"
RDEPENDS_${PN}_class-target += " \
parted (>= 2.3) \
- ${PYTHON_PN}-subprocess \
"
RDEPENDS_${PN}_class-native = ""
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
index 81d61c62a3..7d00fd7d93 100644
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
@@ -4,7 +4,7 @@ PV = "3.10.7+git${SRCPV}"
inherit distutils
-RDEPENDS_${PN} += "python-stringold python-codecs python-math"
+RDEPENDS_${PN} += "python-stringold python-codecs python-math python-subprocess"
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native"