aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-09 16:42:26 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commit9350b539e0e1f214fbc0b8ce86570810f5deecfb (patch)
tree0142bc7987d54c38be4df5197950d438b23f06cc /meta-python/recipes-devtools
parentd082795744697b6a946374e795bdf9d3767401b9 (diff)
downloadmeta-openembedded-contrib-9350b539e0e1f214fbc0b8ce86570810f5deecfb.tar.gz
python3-bitarray: Upgrade 2.2.3 -> 2.2.5
Upgrade to release 2.2.5: - speedup `find_bit()` and `find_last()` using uint64 checking, this means a speedup for `.find()`, `.index()`, `.search()` and `util.rindex()` - add optional start and stop arguments to `.bytereverse()` - add example to illustrate how unaligned copying works internally - add documentation - add tests Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_2.2.5.bb (renamed from meta-python/recipes-devtools/python/python3-bitarray_2.2.3.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.2.3.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.2.5.bb
index b72ca3b560..f8e2489070 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_2.2.3.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_2.2.5.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/ilanschnell/bitarray"
LICENSE = "PSF"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
-SRC_URI[sha256sum] = "b5d707d9c4aa75e684e21ff1848b234f3d2ff41d5038db89e2465e5527f90c68"
+SRC_URI[sha256sum] = "efb2dc83f0acb832a94af3687eea558d72512cf2e54a64fca56a10aacf57934c"
inherit setuptools3 pypi