aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-17 18:32:58 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-17 18:32:58 -0700
commitd0949e0be60aa3b9a6767e42d570aa9f8d02f8c5 (patch)
treeb55ebc897fe4234a977bac93ecfecc69fdfb1d62 /meta-python/recipes-devtools
parent5ed1b52af7a893ce4763ecf8ef662a667fdc345d (diff)
downloadmeta-openembedded-contrib-d0949e0be60aa3b9a6767e42d570aa9f8d02f8c5.tar.gz
python-pybluez: cleanup recipe; fix RDEPENDS; python3 support
* PYPI_PACKAGE needed to be "PyBluez" * PYPI_PACKAGE_EXT needed to be "zip" * RDEPENDS on python-fcntl Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pybluez.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-pybluez_0.22.bb19
-rw-r--r--meta-python/recipes-devtools/python/python3-pybluez_0.22.bb2
3 files changed, 27 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-pybluez.inc b/meta-python/recipes-devtools/python/python-pybluez.inc
new file mode 100644
index 0000000000..594db23521
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pybluez.inc
@@ -0,0 +1,23 @@
+SUMMARY = "Bluetooth Python extension module"
+DESCRIPTION = "Bluetooth Python extension module to allow Python \
+developers to use system Bluetooth resources. PyBluez works with \
+GNU/Linux and Windows XP."
+HOMEPAGE = "http://karulis.github.io/pybluez/"
+SECTION = "devel/python"
+
+DEPENDS = "bluez5"
+RDEPENDS_${PN} = " \
+ bluez5 \
+ ${PYTHON_PN}-fcntl \
+"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
+
+PYPI_PACKAGE = "PyBluez"
+PYPI_PACKAGE_EXT = "zip"
+
+inherit pypi
+
+SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
+SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
diff --git a/meta-python/recipes-devtools/python/python-pybluez_0.22.bb b/meta-python/recipes-devtools/python/python-pybluez_0.22.bb
index eab9c54209..3158f4b647 100644
--- a/meta-python/recipes-devtools/python/python-pybluez_0.22.bb
+++ b/meta-python/recipes-devtools/python/python-pybluez_0.22.bb
@@ -1,17 +1,2 @@
-DESCRIPTION = "Bluetooth Python extension module"
-HOMEPAGE = "http://karulis.github.io/pybluez/"
-SECTION = "devel/python"
-
-RDEPENDS_${PN} = "bluez5"
-DEPENDS = "bluez5"
-
-LICENSE = "GPL-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
-
-inherit pypi setuptools
-
-SRC_URI = "https://pypi.python.org/packages/c1/98/3149481d508bee174335be6725880f00d297afebe75c15e917af8f6fe169/PyBluez-0.22.zip"
-SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
-SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
-
-S = "${WORKDIR}/PyBluez-${PV}"
+require python-pybluez.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pybluez_0.22.bb b/meta-python/recipes-devtools/python/python3-pybluez_0.22.bb
new file mode 100644
index 0000000000..9712a76085
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybluez_0.22.bb
@@ -0,0 +1,2 @@
+require python-pybluez.inc
+inherit setuptools3