aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-17 17:28:34 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-17 17:49:53 -0700
commit5ed1b52af7a893ce4763ecf8ef662a667fdc345d (patch)
tree1be4789b80289845eafc6a867db59066cbdf8e37 /meta-python/recipes-devtools
parent4598769a96980b756b3489ac71ed46a075cfabd7 (diff)
downloadmeta-openembedded-contrib-5ed1b52af7a893ce4763ecf8ef662a667fdc345d.tar.gz
python-pysnmp: upgrade v4.3.5 -> v4.4.4; inherit pypi; add python3 support
For changes, see: https://github.com/etingof/pysnmp/blob/master/CHANGES.txt Verified that license remains BSD. License-Update: change in copyright year, author email, whitespace Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pysnmp.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-pysnmp_4.3.5.bb25
-rw-r--r--meta-python/recipes-devtools/python/python-pysnmp_4.4.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pysnmp_4.4.4.bb2
4 files changed, 27 insertions, 25 deletions
diff --git a/meta-python/recipes-devtools/python/python-pysnmp.inc b/meta-python/recipes-devtools/python/python-pysnmp.inc
new file mode 100644
index 0000000000..ad9c04da43
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pysnmp.inc
@@ -0,0 +1,23 @@
+SUMMARY = "A pure-Python SNMPv1/v2c/v3 library"
+DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \
+ Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \
+ operation (asyncio, twisted, asyncore) and multiple transports.\
+"
+HOMEPAGE = "https://pypi.python.org/pypi/pysnmp"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ade013674cd6ffd9d5d9f77089733e5e"
+
+PYPI_PACKAGE = "pysnmp"
+
+SRC_URI[md5sum] = "a8a5d85d7dd38ffaa6653a3b73494ce3"
+SRC_URI[sha256sum] = "2f363106ad1518d9ef81c1f04b3764a77f9e5fac0303e3148ceb4261c9c6fcca"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pycrypto \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pysmi \
+"
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pysnmp_4.3.5.bb b/meta-python/recipes-devtools/python/python-pysnmp_4.3.5.bb
deleted file mode 100644
index 0b38d58e4a..0000000000
--- a/meta-python/recipes-devtools/python/python-pysnmp_4.3.5.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "A pure-Python SNMPv1/v2c/v3 library"
-DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \
- Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \
- operation (asyncio, twisted, asyncore) and multiple transports.\
-"
-HOMEPAGE = "https://pypi.python.org/pypi/pysnmp"
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=280606d9c18f200e03e0c247ac61475a"
-
-SRCNAME = "pysnmp"
-
-SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "387aaa23c168ccc0b59775cfdf519fc0"
-SRC_URI[sha256sum] = "38253fe95cea33f352fb36e85f3c2874043401724300c4888df74835161169d2"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
-
-RDEPENDS_${PN} += "python-pycrypto \
- python-pyasn1 \
- python-pysmi \
-"
diff --git a/meta-python/recipes-devtools/python/python-pysnmp_4.4.4.bb b/meta-python/recipes-devtools/python/python-pysnmp_4.4.4.bb
new file mode 100644
index 0000000000..2c415141ee
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pysnmp_4.4.4.bb
@@ -0,0 +1,2 @@
+require python-pysnmp.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pysnmp_4.4.4.bb b/meta-python/recipes-devtools/python/python3-pysnmp_4.4.4.bb
new file mode 100644
index 0000000000..2c415141ee
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pysnmp_4.4.4.bb
@@ -0,0 +1,2 @@
+require python-pysnmp.inc
+inherit setuptools