aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDaniel Dragomir <daniel.dragomir@windriver.com>2018-03-08 18:54:55 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:27:54 -0700
commit10fdb67d10dee74be4be47f2c4a2276ada32df0f (patch)
tree8b1b8d802df9d28b88202bf31a6c69b5c2c88066 /meta-python/recipes-devtools
parente109bf6c9ce50f5b6e033da7031b39fc9cb2b351 (diff)
downloadmeta-openembedded-contrib-10fdb67d10dee74be4be47f2c4a2276ada32df0f.tar.gz
python-pynetlinux: add recipe for 1.1 version
Linux network configuration library for Python. Signed-off-by: Daniel Dragomir <daniel.dragomir@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pynetlinux.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-pynetlinux_1.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pynetlinux_1.1.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pynetlinux.inc b/meta-python/recipes-devtools/python/python-pynetlinux.inc
new file mode 100644
index 0000000000..6a39896279
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pynetlinux.inc
@@ -0,0 +1,11 @@
+SUMMARY = "Linux network configuration library for Python"
+DESCRIPTION = "This library contains Python bindings to ioctl calls"
+SECTION = "devel/python"
+HOMEPAGE = "http://github.com/rlisagor/pynetlinux"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=74e1861736ee959824fe7542323c12e9"
+
+inherit pypi
+
+SRC_URI[md5sum] = "3336e5d4a478acca4e35bf3125b4f883"
+SRC_URI[sha256sum] = "4ad08298c9f5ba15a11cddc639ba8778cabdfc402b51066d9e0a325e5a5b391c"
diff --git a/meta-python/recipes-devtools/python/python-pynetlinux_1.1.bb b/meta-python/recipes-devtools/python/python-pynetlinux_1.1.bb
new file mode 100644
index 0000000000..c45ad6ad66
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pynetlinux_1.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pynetlinux.inc
diff --git a/meta-python/recipes-devtools/python/python3-pynetlinux_1.1.bb b/meta-python/recipes-devtools/python/python3-pynetlinux_1.1.bb
new file mode 100644
index 0000000000..f6d9e3c06e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pynetlinux_1.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pynetlinux.inc