aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-04-02 20:35:06 +0800
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-04-06 14:55:16 -0400
commit048db8d5e2213dcae9c695cf196350f2a16b372b (patch)
treea80d1d0c2d9648fc7feb54a1c3b95d8afa504207 /meta-python/recipes-devtools
parent667c8e52da6a766a4eb6d413c74f60efde6d64d1 (diff)
downloadmeta-openembedded-contrib-048db8d5e2213dcae9c695cf196350f2a16b372b.tar.gz
python3-click: upgrade 8.0.4 -> 8.1.2
Changelog from 8.0.4 to 8.1.2: ============================== - Fix error message for readable path check that was mixed up with the executable check. #2236 - Restore parameter order for Path, placing the executable parameter at the end. It is recommended to use keyword arguments instead of positional arguments. #2235 - Fix an issue with decorator typing that caused type checking to report that a command was not callable. #2227 - Drop support for Python 3.6. #2129 - Remove previously deprecated code. #2130 - Group.resultcallback is renamed to result_callback. - autocompletion parameter to Command is renamed to shell_complete. - get_terminal_size is removed, use shutil.get_terminal_size instead. - get_os_args is removed, use sys.argv[1:] instead. - Rely on PEP 538 and PEP 540 to handle selecting UTF-8 encoding instead of ASCII. Click's locale encoding detection is removed. #2198 - Single options boolean flags with show_default=True only show the default if it is True. #1971 - The command and group decorators can be applied with or without parentheses. #1359 - The Path type can check whether the target is executable. #1961 - Command.show_default overrides Context.show_default, instead of the other way around. #1963 - Parameter decorators and @group handles cls=None the same as not passing cls. @option handles help=None the same as not passing help. #1959 - A flag option with required=True requires that the flag is passed instead of choosing the implicit default value. #1978 - Indentation in help text passed to Option and Command is cleaned the same as using the @option and @command decorators does. A command's epilog and short_help are also processed. #1985 - Store unprocessed Command.help, epilog and short_help strings. Processing is only done when formatting help text for output. #2149 - Allow empty str input for prompt() when confirmation_prompt=True and default="". #2157 - Windows glob pattern expansion doesn't fail if a value is an invalid pattern. #2195 - It's possible to pass a list of params to @command. Any params defined with decorators are appended to the passed params. #2131. - @command decorator is annotated as returning the correct type if a cls argument is used. #2211 - A Group with invoke_without_command=True and chain=False will invoke its result callback with the group function's return value. #2124 - to_info_dict will not fail if a ParamType doesn't define a name. #2168 - Shell completion prioritizes option values with option prefixes over new options. #2040 - Options that get an environment variable value using autoenvvar_prefix treat an empty value as None, consistent with a direct envvar. #2146 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-click_8.1.2.bb (renamed from meta-python/recipes-devtools/python/python3-click_8.0.4.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click_8.0.4.bb b/meta-python/recipes-devtools/python/python3-click_8.1.2.bb
index 76f7a8e652..a623fe104c 100644
--- a/meta-python/recipes-devtools/python/python3-click_8.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-click_8.1.2.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://click.pocoo.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
-SRC_URI[sha256sum] = "8458d7b1287c5fb128c90e23381cf99dcde74beaf6c7ff6384ce84d6fe090adb"
+SRC_URI[sha256sum] = "479707fe14d9ec9a0757618b7a100a0ae4c4e236fac5b7f80ca68028141a1a72"
inherit pypi setuptools3 ptest