aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorBinghua Guan <freebendy@gmail.com>2018-07-25 21:29:15 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-27 07:19:14 -0700
commit0049076c41d547a90bfdfe826038d6ce6c23bd36 (patch)
tree591e410836dc20f4fc0b965b41bc54a88d54a5f5 /meta-python/recipes-devtools
parent36c553652fb674778dc5d84cfb74185b9cc2ae23 (diff)
downloadmeta-openembedded-contrib-0049076c41d547a90bfdfe826038d6ce6c23bd36.tar.gz
meta-python: add python-crcmod recipe
Signed-off-by: Binghua Guan <freebendy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-crcmod.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-crcmod_1.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-crcmod_1.7.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-crcmod.inc b/meta-python/recipes-devtools/python/python-crcmod.inc
new file mode 100644
index 0000000000..85da7cb3c2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-crcmod.inc
@@ -0,0 +1,14 @@
+SUMMARY = "A Python module for generating objects that compute the Cyclic Redundancy Check."
+HOMEPAGE = "https://pypi.org/project/crcmod"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2"
+
+SRC_URI[md5sum] = "2d5b92117d958dcead94f9e17f54cd32"
+SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-unittest"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-crcmod_1.7.bb b/meta-python/recipes-devtools/python/python-crcmod_1.7.bb
new file mode 100644
index 0000000000..45b9a2ce66
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-crcmod_1.7.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-crcmod.inc
diff --git a/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb b/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb
new file mode 100644
index 0000000000..6996b13d0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-crcmod.inc