aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-09-02 13:22:08 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-02 12:52:45 -0700
commitdc66ca8495eb051e1e6de5333e36f7f8054094a1 (patch)
tree10a9d9073ad1893fb6ece712f55ea7fe85f9d8da /meta-python/recipes-devtools
parent05d4ee94cc46d4cd7feac661c6d43c1d9d8b0eb1 (diff)
downloadmeta-openembedded-contrib-dc66ca8495eb051e1e6de5333e36f7f8054094a1.tar.gz
python-cmd2: Add python3 version
Providing a python3 version of python-cmd2. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-cmd2.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb9
3 files changed, 24 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-cmd2.inc b/meta-python/recipes-devtools/python/python-cmd2.inc
new file mode 100644
index 0000000000..1a0be778b2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cmd2.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "http://packages.python.org/cmd2/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01aeabea7ae1529a8e4b674b7107d6bc"
+
+SRC_URI[md5sum] = "df35bb2dca8f5e1f6090e1f0aa02960a"
+SRC_URI[sha256sum] = "4b78379d53aff811d1deac720bbe71661769822a5fb2d830cd730656d180fb3d"
+
+inherit pypi
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb b/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
index 94db37a2d3..17b6ae2858 100644
--- a/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
+++ b/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
@@ -1,14 +1,5 @@
-SUMMARY = "Extra features for standard library's cmd module"
-HOMEPAGE = "http://packages.python.org/cmd2/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=01aeabea7ae1529a8e4b674b7107d6bc"
-
-SRC_URI[md5sum] = "df35bb2dca8f5e1f6090e1f0aa02960a"
-SRC_URI[sha256sum] = "4b78379d53aff811d1deac720bbe71661769822a5fb2d830cd730656d180fb3d"
-
-inherit pypi setuptools
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+inherit setuptools
+require python-cmd2.inc
RDEPENDS_${PN} += "\
${PYTHON_PN}-doctest \
@@ -21,5 +12,3 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-threading \
${PYTHON_PN}-textutils \
"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb b/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
new file mode 100644
index 0000000000..f5c5c7e1a3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
@@ -0,0 +1,9 @@
+inherit setuptools3
+require python-cmd2.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-pyperclip \
+ ${PYTHON_PN}-colorama \
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-wcwidth \
+ "