aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorMaciej Pijanowski <maciej.pijanowski@3mdeb.com>2019-08-13 20:24:13 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-14 16:03:43 -0700
commitcf453be9f232424af551273a9aa76a5bf6e4a29b (patch)
tree9663f271f473007683b37a776bac68e3bb8cc087 /meta-python/recipes-devtools
parent28ae6b2cea0d940d66764b102595f0fe5447e93a (diff)
downloadmeta-openembedded-contrib-cf453be9f232424af551273a9aa76a5bf6e4a29b.tar.gz
python3-aiofiles: add recipe
Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-aiofiles.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-aiofiles_0.4.0.bb2
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-aiofiles.inc b/meta-python/recipes-devtools/python/python-aiofiles.inc
new file mode 100644
index 0000000000..3ecb21c86d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-aiofiles.inc
@@ -0,0 +1,14 @@
+SUMMARY = "File support for asyncio"
+DESCRIPTION = "Asynchronous local file IO library for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[md5sum] = "cb33cf96c371fbd56fc27ab0bd81bd61"
+SRC_URI[sha256sum] = "021ea0ba314a86027c166ecc4b4c07f2d40fc0f4b3a950d1868a0f2571c2bbee"
+
+PYPI_PACKAGE = "aiofiles"
+inherit pypi
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"
diff --git a/meta-python/recipes-devtools/python/python3-aiofiles_0.4.0.bb b/meta-python/recipes-devtools/python/python3-aiofiles_0.4.0.bb
new file mode 100644
index 0000000000..b4d188b2ed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiofiles_0.4.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-aiofiles.inc