aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-09-03 09:16:01 +0000
committerKhem Raj <raj.khem@gmail.com>2019-09-03 07:11:04 -0700
commitc20f2aa82f184d6a4a15fc927f0a887e30bbbe2c (patch)
tree4eadd4f71e9ebd397d30da53814260e72f19ee18 /meta-python/recipes-devtools
parenta1a0e8d91e15fb00abcdbd7efe90382b209193fc (diff)
downloadmeta-openembedded-contrib-c20f2aa82f184d6a4a15fc927f0a887e30bbbe2c.tar.gz
python3-pyatspi: restrict with GTK2DISTROFEATURES
* fixes: NOTE: Resolving any missing task queue dependencies ERROR: Nothing PROVIDES 'gtk+' (but meta-oe/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb DEPENDS on or otherwise requires it) gtk+ was skipped: one of 'x11 directfb' needs to be in DISTRO_FEATURES ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'python3-pyatspi', 'gtk+'] Summary: There was 1 WARNING message shown. Summary: There were 2 ERROR messages shown, returning a non-zero exit code. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb b/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
index 6d80c10915..c60d40e3a2 100644
--- a/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
@@ -11,6 +11,10 @@ SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=gnome-3-32"
SRCREV = "dc4565208fca00da06b972915a080ad3c63f640d"
S = "${WORKDIR}/git"
+# Same restriction as gtk+
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
inherit pkgconfig autotools python3native
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"