aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@wdc.com>2019-09-11 10:23:38 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-11 12:22:33 -0700
commit7833700fcfba8304b30d63f228aa861b0279c854 (patch)
treeefee8ad3a2a0d53a09e09054c446053558783453 /meta-python/recipes-devtools
parent9f607e4ba6ea6c6ffb977b1f9a8bb117396aa9ec (diff)
downloadmeta-openembedded-contrib-7833700fcfba8304b30d63f228aa861b0279c854.tar.gz
python3-requests-future: Initial commit of 0.9.5
Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb b/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb
new file mode 100644
index 0000000000..b94929d8c6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Small add-on for the python requests http library. Makes use of python 3.2’s concurrent.futures or the backport for prior versions of python."
+HOMEPAGE = "https://github.com/ross/requests-futures"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e1e50798d0afe0e1f87594c6619a2fa5"
+
+SRC_URI[md5sum] = "e20dc6f063c70888a7f8225e349b6682"
+SRC_URI[sha256sum] = "33aa8a3b7892850701707d7e094b1e1ce7c4f7a36ff2a1dcc2da4e01a1a00f7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ python3-requests \
+"
+