aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-09-19 12:23:01 +0900
committerKhem Raj <raj.khem@gmail.com>2019-09-19 00:09:43 -0700
commit5b98315d1955adcaf30c6d8589d6f39692e45a69 (patch)
tree0bd466159c94152f588bc8072f957a6c491e98e7 /meta-python/recipes-devtools
parenta62ed77703fd9fe9ae9581f14e1e1a3c9a3197d8 (diff)
downloadmeta-openembedded-contrib-5b98315d1955adcaf30c6d8589d6f39692e45a69.tar.gz
python-more-itertools: new recipe
Add new recipe python-more-itertools as it is RDEPEND of python-zipp and python-pytest. Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-more-itertools.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-more-itertools_7.2.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-more-itertools_7.2.0.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-more-itertools.inc b/meta-python/recipes-devtools/python/python-more-itertools.inc
new file mode 100644
index 0000000000..41c334e8d7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-more-itertools.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "More routines for operating on iterables, beyond itertools"
+HOMEPAGE = "https://github.com/erikrose/more-itertools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
+
+SRC_URI[md5sum] = "f647bfd27243a7bebe53b5ddb6a3b1c4"
+SRC_URI[sha256sum] = "409cd48d4db7052af495b09dec721011634af3753ae1ef92d2b32f73a745f832"
+
+inherit pypi setuptools3
diff --git a/meta-python/recipes-devtools/python/python-more-itertools_7.2.0.bb b/meta-python/recipes-devtools/python/python-more-itertools_7.2.0.bb
new file mode 100644
index 0000000000..0702aad4ef
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-more-itertools_7.2.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-more-itertools.inc
diff --git a/meta-python/recipes-devtools/python/python3-more-itertools_7.2.0.bb b/meta-python/recipes-devtools/python/python3-more-itertools_7.2.0.bb
new file mode 100644
index 0000000000..28ddf88fb8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-more-itertools_7.2.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-more-itertools.inc