aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-01-15 09:17:06 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-17 13:41:43 -0800
commitef0d1fe4b05d4e9a3bf9de0d3ab97010d1dff2a0 (patch)
tree7dc10b170ecca4ee2f00f2a6b150ecb7d707e18e /meta-python/recipes-devtools
parent466c185a1abdcb896a0112328335ed4fe61a9222 (diff)
downloadmeta-openembedded-contrib-ef0d1fe4b05d4e9a3bf9de0d3ab97010d1dff2a0.tar.gz
python-pyjwt: add initial recipe for version 1.5.3
Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pyjwt.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-pyjwt_1.5.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjwt_1.5.3.bb2
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyjwt.inc b/meta-python/recipes-devtools/python/python-pyjwt.inc
new file mode 100644
index 0000000000..dda4b942d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyjwt.inc
@@ -0,0 +1,17 @@
+SUMMARY = "JSON Web Token implementation in Python"
+SUMMARY = "JSON Web Token implementation in Python"
+DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
+ Original implementation was written by https://github.com/progrium"
+HOMEPAGE = "http://github.com/jpadilla/pyjwt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
+
+SRC_URI[md5sum] = "739494379f582ca98c89fb7ac229915b"
+SRC_URI[sha256sum] = "500be75b17a63f70072416843dc80c8821109030be824f4d14758f114978bae7"
+
+PYPI_PACKAGE = "PyJWT"
+inherit pypi
+
+RDEPENDS_${PN} = "${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyjwt_1.5.3.bb b/meta-python/recipes-devtools/python/python-pyjwt_1.5.3.bb
new file mode 100644
index 0000000000..f0a77b674b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyjwt_1.5.3.bb
@@ -0,0 +1,2 @@
+require python-pyjwt.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_1.5.3.bb b/meta-python/recipes-devtools/python/python3-pyjwt_1.5.3.bb
new file mode 100644
index 0000000000..dc16d22825
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_1.5.3.bb
@@ -0,0 +1,2 @@
+require python-pyjwt.inc
+inherit setuptools3