aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-26 11:12:29 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-30 12:33:19 -0800
commitb91c5dcb0d2542adc704c39b96e1b91c35018a6a (patch)
tree26a11b92e272ec147aaa7ff8d6ed7c954d8021fa /meta-python/recipes-devtools
parentbc8e40e7abc21aa920414a7056e410c0bb2438c6 (diff)
downloadmeta-openembedded-contrib-b91c5dcb0d2542adc704c39b96e1b91c35018a6a.tar.gz
python-pyperclip: add an initial recipe for version 1.6.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pyperclip.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyperclip.inc b/meta-python/recipes-devtools/python/python-pyperclip.inc
new file mode 100644
index 0000000000..c712fdd7c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyperclip.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1ed92115c8f96b19ec34ed09df586e51"
+
+SRC_URI[md5sum] = "d2f6a3129cd6f2518b52bb0b8deeeda7"
+SRC_URI[sha256sum] = "ce829433a9af640e08ee89b20f7c62132714bcc5d77df114044d0fccb8c3b3b8"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-subprocess \
+"
diff --git a/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb b/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb
new file mode 100644
index 0000000000..6e93b81796
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb
@@ -0,0 +1,4 @@
+inherit setuptools
+require python-pyperclip.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-contextlib"
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb
new file mode 100644
index 0000000000..ee6f88bbbc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pyperclip.inc