aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-13 14:16:55 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-23 08:44:44 -0700
commitffc64e9c6fee0af7eea3466135416d011172a5e6 (patch)
treeb9effa069d9af3c63d6f3a41caff6b887450522c /meta-python/recipes-devtools/python
parenta90f89dbc7eff2ae83bab6a6676f4737c0b48a8d (diff)
downloadmeta-openembedded-contrib-ffc64e9c6fee0af7eea3466135416d011172a5e6.tar.gz
recipes: Start WORKDIR -> UNPACKDIR transition
Replace references of WORKDIR with UNPACKDIR where it makes sense to do so in preparation for changing the default value of UNPACKDIR. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cloudpickle_3.0.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-jstyleson_0.0.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-stopit_1.1.2.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor_4.2.5.bb4
5 files changed, 7 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cloudpickle_3.0.0.bb b/meta-python/recipes-devtools/python/python3-cloudpickle_3.0.0.bb
index 25c379590f..fce5a5b408 100644
--- a/meta-python/recipes-devtools/python/python3-cloudpickle_3.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cloudpickle_3.0.0.bb
@@ -8,7 +8,7 @@ data."
HOMEPAGE = "https://github.com/cloudpipe/cloudpickle"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.cloudpickle;md5=b4d59aa5e2cc777722aac17841237931"
+LIC_FILES_CHKSUM = "file://${UNPACKDIR}/LICENSE.cloudpickle;md5=b4d59aa5e2cc777722aac17841237931"
inherit pypi python_flit_core
diff --git a/meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb b/meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb
index 6b31d0b4f5..a6c3e139b8 100644
--- a/meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb
+++ b/meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb
@@ -22,7 +22,7 @@ addtask do_patchbuild after do_patch before do_configure
do_patchbuild () {
rm -f ${S}/CMakeLists.txt
- cp ${WORKDIR}/CMakeLists.txt ${S}/
+ cp ${UNPACKDIR}/CMakeLists.txt ${S}/
}
do_install:append () {
diff --git a/meta-python/recipes-devtools/python/python3-jstyleson_0.0.2.bb b/meta-python/recipes-devtools/python/python3-jstyleson_0.0.2.bb
index 237713bf12..ff9d7dd552 100644
--- a/meta-python/recipes-devtools/python/python3-jstyleson_0.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-jstyleson_0.0.2.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/linjackson78/jstyleson"
SRC_URI += " file://LICENSE "
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=d97b96c7337934ee448ffd4392f32079"
+LIC_FILES_CHKSUM = "file://${UNPACKDIR}/LICENSE;md5=d97b96c7337934ee448ffd4392f32079"
PYPI_PACKAGE_EXT = "tar.gz"
diff --git a/meta-python/recipes-devtools/python/python3-stopit_1.1.2.bb b/meta-python/recipes-devtools/python/python3-stopit_1.1.2.bb
index e119a0f11a..a952722619 100644
--- a/meta-python/recipes-devtools/python/python3-stopit_1.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-stopit_1.1.2.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
SRC_URI += " file://LICENSE "
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=497c556f42b1355b64190da2f3d88f93"
+LIC_FILES_CHKSUM = "file://${UNPACKDIR}/LICENSE;md5=497c556f42b1355b64190da2f3d88f93"
SRC_URI[sha256sum] = "f7f39c583fd92027bd9d06127b259aee7a5b7945c1f1fa56263811e1e766996d"
@@ -14,4 +14,4 @@ RDEPENDS:${PN} += "\
python3-setuptools \
"
-BBCLASSEXTEND = "native nativesdk" \ No newline at end of file
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.2.5.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.2.5.bb
index 06b08e78a3..e104e1c0ce 100644
--- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.5.bb
+++ b/meta-python/recipes-devtools/python/python3-supervisor_4.2.5.bb
@@ -28,6 +28,6 @@ do_install:append() {
install -d ${D}${sysconfdir}/supervisor
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
- install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
+ install -m 0644 ${UNPACKDIR}/supervisor.service ${D}${systemd_system_unitdir}
}