aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-06-16 01:39:06 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:58:02 -0700
commitf961225a1c25b66cbe7941c992c606441ed00abb (patch)
tree7683060fbcf326318c23728572a27a6932c72d02 /meta-python/recipes-devtools/python
parent393ed2a056f26a2dd674dcff20be4d1a30c22113 (diff)
downloadmeta-openembedded-contrib-f961225a1c25b66cbe7941c992c606441ed00abb.tar.gz
python3-dominate: Enable ptest
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate/run-ptest b/meta-python/recipes-devtools/python/python3-dominate/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dominate/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb b/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
index dd8c596035..75dd4ef9f6 100644
--- a/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
@@ -5,7 +5,20 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
SRC_URI[md5sum] = "35eeb6b5587c8c9a51cd22c83e07ac49"
SRC_URI[sha256sum] = "9b05481605ea8c0afd0a98c0156a9fb78d9c406368d66b3e6fedf36920fb9d78"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
RDEPENDS_${PN} += "\
${PYTHON_PN}-numbers \