aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@fujitsu.com>2021-08-04 09:23:53 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:37:42 -0700
commitea33b88613bb18897545175127c9e17ec1b2e9a7 (patch)
treeaab5e55203e23eb2de883edd9fb57491e2350860 /meta-python/recipes-devtools/python
parentc704cb00629dd66d20547b592b6add7ff6d2c1aa (diff)
downloadmeta-openembedded-contrib-ea33b88613bb18897545175127c9e17ec1b2e9a7.tar.gz
python3-robotframework: upgrade 4.0.3 -> 4.1
Add runtime dependency to resolve errors that occurred when import robot. Robot Framework 4.1 is a feature release with several nice enhancements, for example, to the continue-on-failure mode and argument conversion, as well as some bug fixes. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_4.1.bb (renamed from meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb)4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb b/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
index cc6c9758b3..7c6c41af7c 100644
--- a/meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
@@ -13,7 +13,7 @@ inherit pypi setuptools3
PYPI_PACKAGE_EXT = "zip"
-SRC_URI[sha256sum] = "93c2107f789fd897f234f4b8f1ba8e7b9f4ef326d9bcbfceb71dda8cc197388c"
+SRC_URI[sha256sum] = "567f2a21f0906635e21d45fe3cb84a4809a12980c9f2706a8a5f65f40f6b4ccd"
RDEPENDS:${PN} += " \
${PYTHON_PN}-shell \
@@ -24,4 +24,6 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-html \
${PYTHON_PN}-docutils \
${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
"