aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2021-08-05 11:59:06 +0930
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:37:42 -0700
commitbf1057e64076c9e6909cf694cfae2b8a1991d341 (patch)
treea0ca1a1807635eb439a48b093543cd329997395d /meta-python/recipes-devtools/python
parent92d469b26a33eee558298b7c8a5e9807dffa6740 (diff)
downloadmeta-openembedded-contrib-bf1057e64076c9e6909cf694cfae2b8a1991d341.tar.gz
python3-ecdsa: Add native support
python3-ecdsa is a dependency of meta-aspeed's socsec package. socsec is a set of tools for signing bootloaders and forming a hardware root of trust for ASPEED BMC SoCs. Signed-off-by: Andrew Jeffery <andrew@aj.id.au> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
index a217ecd224..177019ccc2 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
@@ -8,6 +8,8 @@ DEPENDS += "python3-pip python3-pbr"
PYPI_PACKAGE = "ecdsa"
SRC_URI[sha256sum] = "b9f500bb439e4153d0330610f5d26baaf18d17b8ced1bc54410d189385ea68aa"
-inherit pypi setuptools3
+inherit pypi setuptools3 python3native
RDEPENDS:${PN} += "python3-six python3-gmpy2 python3-pbr"
+
+BBCLASSEXTEND = "native nativesdk"