aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-08-17 11:00:01 -0400
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:56:43 -0700
commitbd4804580b42c7aee046335e916da1d1aa991f37 (patch)
treee7294b0e4221a558bfb27be28aa7006d5391f0e7 /meta-python/recipes-devtools/python
parentf58bd1789ad840b04fa36212d67cebbe14ed21e5 (diff)
downloadmeta-openembedded-contrib-bd4804580b42c7aee046335e916da1d1aa991f37.tar.gz
python3-click: Add missing ptest artifacts
The click ptests require the top-level setup.cfg and the docs/conf.py file to be present in the PTEST_PATH, so add steps to copy them to the image when building the ptest. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-click_8.0.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click_8.0.1.bb b/meta-python/recipes-devtools/python/python3-click_8.0.1.bb
index be13570b59..c8b9a429ed 100644
--- a/meta-python/recipes-devtools/python/python3-click_8.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-click_8.0.1.bb
@@ -23,8 +23,10 @@ RDEPENDS:${PN}-ptest += " \
"
do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
+ cp -rf ${S}/docs ${D}${PTEST_PATH}/
}
UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"