aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-01 15:51:32 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-02 08:55:52 -0700
commit995fc86b298d5b09fdd6288b9e9f4211feea3b18 (patch)
treec94e67b332d6fcdef0fd5377ab7e08a7a52820d0 /meta-python/recipes-devtools/python
parent0036646b10a22ef0900b2e8b228e4eb94ea3e32e (diff)
downloadmeta-openembedded-contrib-995fc86b298d5b09fdd6288b9e9f4211feea3b18.tar.gz
python3-pillow: Upgrade 6.2.1 -> 7.2.0
Upgrade to release 7.2.0: - Do not convert I;16 images when showing PNGs - Fixed ICNS file pointer saving - Fixed loading non-RGBA mode APNGs with dispose background - Deprecated _showxv - Deprecate Image.show(command="...") - Updated JPEG magic number - Change STRIPBYTECOUNTS to LONG if necessary when saving - Write JFIF header when saving JPEG - Replaced tiff_jpeg with jpeg compression when saving TIFF images - Writing TIFF tags: improved BYTE, added UNDEFINED - Consider transparency when pasting text on an RGBA image - Added method argument to single frame WebP saving - Use ImageFileDirectory_v2 in Image.Exif - Corrected reading EXIF metadata without prefix - Fixed drawing a jointed line with a sequence of numeric values - Added support for 1-D NumPy arrays - Parse orientation from XMP tags - Speed up text layout by not rendering glyphs - Fixed ZeroDivisionError in Image.thumbnail - Replaced TiffImagePlugin DEBUG with logging - Fix repeatedly loading .gbr - JPEG: Truncate icclist instead of setting to None - Fixes default offset for Exif - Fixed bug when unpickling TIFF images - Fix pickling WebP - Replace IOError and WindowsError aliases with OSError License-Update: Word wrap and updated copyright year. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch19
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb)6
2 files changed, 14 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
index 35aee42145..005fea5c66 100644
--- a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
+++ b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
@@ -1,6 +1,6 @@
-From 862a981ce462cd83a99e3db9faeeda1f8c64983f Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Mon, 18 Mar 2019 23:23:55 -0400
+From 27bfa4028453dc79a72569823e97da8fd1994ffc Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Tue, 1 Sep 2020 11:53:53 +0000
Subject: [PATCH] explicitly set compile options
OE does not support to install egg package, so
@@ -10,19 +10,19 @@ explicitly set build_ext options for oe-core's
Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
setup.cfg | 12 ++++++++++++
1 file changed, 12 insertions(+)
diff --git a/setup.cfg b/setup.cfg
-index 1c6ebc84..1ccc3d69 100644
+index 19979cf7..ed27dfe1 100644
--- a/setup.cfg
+++ b/setup.cfg
-@@ -13,3 +13,15 @@ multi_line_output = 3
-
+@@ -11,3 +11,15 @@ multi_line_output = 3
[tool:pytest]
- addopts = -rs
+ addopts = -ra --color=yes
+ testpaths = Tests
+
+[build_ext]
+disable-platform-guessing = 1
@@ -35,3 +35,6 @@ index 1c6ebc84..1ccc3d69 100644
+disable-webp = 1
+disable-webpmux = 1
+disable-imagequant = 1
+--
+2.17.1
+
diff --git a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb b/meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb
index a383a3ff91..13cab43008 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb
@@ -3,13 +3,13 @@ Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
Contributors."
HOMEPAGE = "https://pillow.readthedocs.io"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=55c0f320370091249c1755c0d2b48e89"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea2dc3f5611e69058503d4b940049d03"
-SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=6.2.x \
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=7.2.x \
file://0001-support-cross-compiling.patch \
file://0001-explicitly-set-compile-options.patch \
"
-SRCREV ?= "6e0f07bbe38def22d36ee176b2efd9ea74b453a6"
+SRCREV ?= "2bd74943fb9f320def6c066e732b701d1c15f677"
inherit setuptools3