aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMaxin John <maxin.john@intel.com>2018-02-20 10:38:46 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:12:55 -0800
commit19c1b40b4f63ca437aaf78fa17af6fe35372478e (patch)
treec0f1d3b03f16a84553be646460f72e7687e62e6a /meta-python/recipes-devtools/python
parent03f79a311c79c7b43f8e47eba4c5bbe6ab532fa1 (diff)
downloadmeta-openembedded-contrib-19c1b40b4f63ca437aaf78fa17af6fe35372478e.tar.gz
python-evdev: add python3 version of the recipe
Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-evdev.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-evdev_0.7.0.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb2
3 files changed, 18 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-evdev.inc b/meta-python/recipes-devtools/python/python-evdev.inc
new file mode 100644
index 0000000000..ccd5077da2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-evdev.inc
@@ -0,0 +1,15 @@
+SUMMARY = "Python evdev lib"
+HOMEPAGE = "https://github.com/gvalkov/python-evdev"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
+
+SRC_URI[md5sum] = "c7e855ae9f97f869a59e75b29f05ce74"
+SRC_URI[sha256sum] = "57edafc469a414f58b51af1bfb9ee2babb9f626dd2df530d71c1176871850aa1"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+ "
diff --git a/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb b/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
index 0875da45c3..63541363e3 100644
--- a/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
@@ -1,17 +1,2 @@
-SUMMARY = "Python evdev lib"
-HOMEPAGE = "https://github.com/gvalkov/python-evdev"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
-
-SRC_URI[md5sum] = "c7e855ae9f97f869a59e75b29f05ce74"
-SRC_URI[sha256sum] = "57edafc469a414f58b51af1bfb9ee2babb9f626dd2df530d71c1176871850aa1"
-
inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-ctypes \
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-stringold \
- "
+require python-evdev.inc
diff --git a/meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb b/meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb
new file mode 100644
index 0000000000..3a92b6ec96
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-evdev.inc