aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-10 11:29:27 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-12 12:45:11 -0800
commit24b704c9257f86ba8c2d7e837601eab9a20f2677 (patch)
treef8132e3a05e5d5878de738cd323b39cb6072b25f /meta-python/recipes-devtools/python
parent1a3788c9262db65fb6a26cfb7e6d32b1ced96a75 (diff)
downloadmeta-openembedded-contrib-24b704c9257f86ba8c2d7e837601eab9a20f2677.tar.gz
meta-python: Drop RDEPEND'ing on python3-typing
Its part of core python package now Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-argexec_1.0.3.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.3.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb1
8 files changed, 0 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto.inc b/meta-python/recipes-devtools/python/python-m2crypto.inc
index 81c81645af..797a0354bf 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto.inc
+++ b/meta-python/recipes-devtools/python/python-m2crypto.inc
@@ -25,7 +25,6 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \
${PYTHON_PN}-smtpd \
- ${PYTHON_PN}-typing \
${PYTHON_PN}-xmlrpc \
"
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb
index 178e68bd97..6cd5a4cab5 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.2.bb
@@ -16,6 +16,5 @@ RDEPENDS_${PN} = "\
${PYTHON_PN}-idna-ssl \
${PYTHON_PN}-misc \
${PYTHON_PN}-multidict \
- ${PYTHON_PN}-typing \
${PYTHON_PN}-yarl \
"
diff --git a/meta-python/recipes-devtools/python/python3-argexec_1.0.3.bb b/meta-python/recipes-devtools/python/python3-argexec_1.0.3.bb
index a26835b607..9f152a1d60 100644
--- a/meta-python/recipes-devtools/python/python3-argexec_1.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-argexec_1.0.3.bb
@@ -9,7 +9,6 @@ SRC_URI[sha256sum] = "61f9ae9322e38ae64996848421afbdb018239a99c4e796fe064f172d6c
DEPENDS += "python3-setuptools-scm-native"
RDEPENDS_${PN} += "\
- python3-typing \
python3-dynamic-dispatch \
python3-typeguard \
"
diff --git a/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
index 2bf487584a..0ed5df1b2e 100644
--- a/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
@@ -12,7 +12,6 @@ PYPI_PACKAGE = "dynamic_dispatch"
DEPENDS += "python3-setuptools-scm-native"
RDEPENDS_${PN} += "\
- python3-typing \
python3-typeguard \
"
diff --git a/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb b/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb
index 2bf9d07533..70527e026c 100644
--- a/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb
+++ b/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb
@@ -15,7 +15,6 @@ RDEPENDS_${PN} += "\
python3-json \
python3-logging \
python3-netclient \
- python3-typing \
"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.3.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.3.bb
index 98db23039b..75a0926f08 100644
--- a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.3.bb
@@ -17,7 +17,6 @@ RDEPENDS_${PN} += "\
python3-logging \
python3-netclient \
python3-pkgutil \
- python3-typing \
"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb b/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
index bd92216776..cb5c372352 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb
@@ -28,6 +28,4 @@ DEPENDS += "\
python3-setuptools-scm-native \
"
-RDEPENDS_${PN} += "python3-typing"
-
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb b/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
index b950d6f632..e567e0ba28 100644
--- a/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
@@ -9,7 +9,6 @@ inherit pypi setuptools3 ptest
RDEPENDS_${PN}_class-target = "\
${PYTHON_PN}-stringold \
- ${PYTHON_PN}-typing \
"
SRC_URI += " \