aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorniko.mauno@vaisala.com <niko.mauno@vaisala.com>2020-05-09 17:06:01 +0000
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:41:35 -0700
commit3ab088ccdc35e1ad04ceb44efbe240dbb7513945 (patch)
tree8ae5a7e7b77a9ada23a7f4b8b6a35aad483fd015 /meta-python/recipes-devtools/python
parentbb93e3c6ff622689ab08fda93bd2a129bc660ff5 (diff)
downloadmeta-openembedded-contrib-3ab088ccdc35e1ad04ceb44efbe240dbb7513945.tar.gz
python3-attrs: Add nativesdk to BBCLASSEXTEND
By doing so we mitigate failure when trying to bitbake recipe which rdepends on nativesdk-python3-attrs, such as following error when bitbaking nativesdk-python3-jsonschema: ERROR: Nothing RPROVIDES 'nativesdk-python3-attrs' (but virtual:nativesdk:.../meta-openembedded/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb RDEPENDS on or otherwise requires it) Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 129efc7fa0c04ee812a972fc5b63990fe74288ea) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
index b3739fda8c..7ff8049e52 100644
--- a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
@@ -12,5 +12,9 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-crypt \
${PYTHON_PN}-ctypes \
"
+RDEPENDS_${PN}_class-nativesdk += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"