aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:33 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-27 10:53:58 -0700
commitc591e5d84ce6820aff7e24a8a91956b2f1e87dd6 (patch)
treea01cd8e61a02607c492cbd6ac8188b45938da84b /meta-python/recipes-devtools/python
parente78cf913076ba28633d0ec4540f15820a0d944d2 (diff)
downloadmeta-openembedded-contrib-c591e5d84ce6820aff7e24a8a91956b2f1e87dd6.tar.gz
python{, 3}-pint: add recipes for python2 and python3
Add recipe for physical quantities module for python2 and python3 infrastructure of Yocto. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pint.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-pint_0.8.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.8.1.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pint.inc b/meta-python/recipes-devtools/python/python-pint.inc
new file mode 100644
index 0000000000..53f7783934
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pint.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Interval arithmetic for Python"
+HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi
+
+SRC_URI[md5sum] = "e1f80f3f8fc4e61f68ad3912db26b3a8"
+SRC_URI[sha256sum] = "afcf31443a478c32bbac4b00337ee9026a13d0e2ac83d30c79151462513bb0d4"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-pint_0.8.1.bb b/meta-python/recipes-devtools/python/python-pint_0.8.1.bb
new file mode 100644
index 0000000000..480f088721
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pint_0.8.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pint.inc
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.8.1.bb b/meta-python/recipes-devtools/python/python3-pint_0.8.1.bb
new file mode 100644
index 0000000000..f793ac4ace
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.8.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pint.inc