aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:34 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-27 10:53:58 -0700
commit218c1e74b78068031c77df2c712a754d1e7ff160 (patch)
treeb6c3fbe75369adfd209e40498bbe727b2a64a946 /meta-python/recipes-devtools/python
parentc591e5d84ce6820aff7e24a8a91956b2f1e87dd6 (diff)
downloadmeta-openembedded-contrib-218c1e74b78068031c77df2c712a754d1e7ff160.tar.gz
python{, 3}-intervals: add recipes for python2/3
Add recipe for interval arithmetic for python supporting python2 as well as python3 infrastructure of Yocto. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-intervals.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-intervals_1.5.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-intervals_1.5.4.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-intervals.inc b/meta-python/recipes-devtools/python/python-intervals.inc
new file mode 100644
index 0000000000..1ecca3524b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-intervals.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Interval arithmetic for Python"
+HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+PYPI_PACKAGE := "python-intervals"
+
+inherit pypi
+
+SRC_URI[md5sum] = "a35dd44269fdb134bf19cfd80cb2c120"
+SRC_URI[sha256sum] = "a8a15b7c2fadb8465310f44aa96e384828b35a29de38ac74738cd665924cb8ac"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-intervals_1.5.4.bb b/meta-python/recipes-devtools/python/python-intervals_1.5.4.bb
new file mode 100644
index 0000000000..3c2a33bbc6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-intervals_1.5.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-intervals.inc
diff --git a/meta-python/recipes-devtools/python/python3-intervals_1.5.4.bb b/meta-python/recipes-devtools/python/python3-intervals_1.5.4.bb
new file mode 100644
index 0000000000..8cbe1090f3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-intervals_1.5.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-intervals.inc