aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-10-30 11:14:18 -0400
committerKhem Raj <raj.khem@gmail.com>2018-11-02 10:05:06 -0700
commit12c394588cbda922482c14616135030f530e8a2e (patch)
tree3945fa10a65a004b4d36699ba5a34e1be4a9accb /meta-python/recipes-devtools/python
parent2731f210ccf7509b5f509fe8b2032d9daba85c4b (diff)
downloadmeta-openembedded-contrib-12c394588cbda922482c14616135030f530e8a2e.tar.gz
python-twisted: Add more python-twisted-* packages to the "meta" package
Whereas the python-twisted-core package is used to install the minimum components of python-twisted, the python-twisted package is essentially a 'meta' package which installs all of the python-twisted-* packages (used by folks that don't want to determine which components they are interested in). Add additional packages to the python-twisted 'meta' package. NOTE: that there are still modules of python-twisted which have not been ported to python3 (see src/twisted/python/_setup.py "notPortedModules") so the installed packages for py2 vs. py3 will not be the same (ie. python-twisted-news is only part of the py2 package). Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc3
-rw-r--r--meta-python/recipes-devtools/python/python-twisted_18.4.0.bb4
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index 260909bdd8..01616b168b 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -49,9 +49,12 @@ RDEPENDS_${PN} = "\
${PN}-conch \
${PN}-mail \
${PN}-names \
+ ${PN}-pair \
+ ${PN}-protocols \
${PN}-runner \
${PN}-web \
${PN}-words \
+ ${PN}-zsh \
"
RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat"
diff --git a/meta-python/recipes-devtools/python/python-twisted_18.4.0.bb b/meta-python/recipes-devtools/python/python-twisted_18.4.0.bb
index 2be1709d04..5903db3e02 100644
--- a/meta-python/recipes-devtools/python/python-twisted_18.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-twisted_18.4.0.bb
@@ -2,3 +2,7 @@ inherit pypi setuptools
require python-twisted.inc
RDEPENDS_${PN}-core += "${PYTHON_PN}-contextlib"
+
+RDEPENDS_${PN} += " \
+ ${PN}-news \
+"