aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-09 11:49:33 +0100
committerKhem Raj <raj.khem@gmail.com>2018-07-12 07:19:42 -0700
commite2d161465630eec09ec66ad11a33c30f17c04a7d (patch)
treed16cae2f92190787f5f41b189e1360032037b4c0 /meta-python/recipes-devtools/python
parent35bae5e006f5010acb2163cc90a7b0d1c34d52e3 (diff)
downloadmeta-openembedded-contrib-e2d161465630eec09ec66ad11a33c30f17c04a7d.tar.gz
python-panda: add cython to DEPENDS
The distutils class does a 'setup.py clean' now, deleting files which then need to be regenerated. Add Cython to the build dependencies so this can be done. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pandas.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pandas.inc b/meta-python/recipes-devtools/python/python-pandas.inc
index a08f1c2861..9b8e4dcf18 100644
--- a/meta-python/recipes-devtools/python/python-pandas.inc
+++ b/meta-python/recipes-devtools/python/python-pandas.inc
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "50b52af2af2e15f4aeb2fe196da073a8c131fa02e433e105d95ce40016
inherit pypi
DEPENDS += " \
- ${PYTHON_PN}-numpy-native \
+ ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
"
RDEPENDS_${PN} += " \