aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-09-12 15:49:28 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-12 02:20:59 -0700
commitffcd5f58636a7bd07d413ab5c8ee36866718ac19 (patch)
treea0b2e37cd1c4aa4b7b53f1902ea62bb4d2f32a5c /meta-python/recipes-devtools/python
parent676fe1c49640162a75ddf254b4752bbd79ba4303 (diff)
downloadmeta-openembedded-contrib-ffcd5f58636a7bd07d413ab5c8ee36866718ac19.tar.gz
python3-networkx: add recipe
networkx only supports python3 starting v2.3. Move the common code to .inc and remove python-2to3 RDEPENDS which is no longer needed: https://github.com/networkx/networkx/commit/4e611d7ea90c20864daba912d6118220d5bbddf3 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-networkx.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-networkx_2.2.bb10
-rw-r--r--meta-python/recipes-devtools/python/python3-networkx_2.3.bb8
3 files changed, 21 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-networkx.inc b/meta-python/recipes-devtools/python/python-networkx.inc
new file mode 100644
index 0000000000..a4c31b2b28
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-networkx.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+LICENSE = "BSD-3-Clause"
+
+inherit pypi
+
+PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-decorator \
+ "
diff --git a/meta-python/recipes-devtools/python/python-networkx_2.2.bb b/meta-python/recipes-devtools/python/python-networkx_2.2.bb
index a2381661cf..648f0312f6 100644
--- a/meta-python/recipes-devtools/python/python-networkx_2.2.bb
+++ b/meta-python/recipes-devtools/python/python-networkx_2.2.bb
@@ -1,12 +1,8 @@
-DESCRIPTION = "Python package for creating and manipulating graphs and networks"
-LICENSE = "BSD-3-Clause"
+require python-networkx.inc
+
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde"
SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a"
SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b"
-PYPI_PACKAGE_EXT = "zip"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "python-2to3"
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.3.bb b/meta-python/recipes-devtools/python/python3-networkx_2.3.bb
new file mode 100644
index 0000000000..8feb6daa32
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-networkx_2.3.bb
@@ -0,0 +1,8 @@
+require python-networkx.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b68290ee1026b204170a23bbdb27a4fd"
+
+SRC_URI[md5sum] = "320d3f6c7872732baa63cedafddadea9"
+SRC_URI[sha256sum] = "8311ddef63cf5c5c5e7c1d0212dd141d9a1fe3f474915281b73597ed5f1d4e3d"
+
+inherit setuptools3